Slido Status
Slido application does not load
Incident Report for Slido
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 06:31 UTC
Update
The root cause of the issue was the mismatch in the root DNS records for one of the domains we use to provide the service. The issue was identified and escalated very quickly; however, our hands were tied, and it took some time until the root registry applied all the necessary fixes.

We are continuing to monitor for any further issues, but we anticipate that some clients might experience certain troubles in the course of the next 48 hours. The reason is that corrupted DNS records might still be present in the browsers and even distributed by some ISPs. Any issues will disappear automatically, but in case you need any assistance with troubleshooting or understanding the situation, please, don't hesitate to reach out to us at support@slido.com

We are very sorry for all the trouble and inconvenience.
Posted Sep 16, 2022 - 23:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2022 - 23:22 UTC
Update
We are currently working on restoring all Slido functionality. There are still problems that we have not been able to fully resolve - mainly connected with the login into the accounts, because of this, we are currently unable to provide a reliable ETA for when full functionality will be restored.
Posted Sep 16, 2022 - 23:16 UTC
Investigating
We have received reports from clients that various components of Slido don't load. We are investigating underlying issues and will give update an update as soon as possible.
Posted Sep 16, 2022 - 21:08 UTC
This incident affected: Slido API, Slido Admin app, Slido Participant app, and Slido Webex integration.