Slido Status
Issues with Google login
Incident Report for Slido
Resolved
Slido users should be good when using Google login for their Slido services.

It has been confirmed that from 16:20 UTC there are no issues with Google login reported.

We apologize for the inconvenience and thank you for your understanding!
Posted Mar 05, 2024 - 16:40 UTC
Identified
Google login is currently experiencing issues and Slido users might be affected.

This may prevent some users from accessing their Slido accounts. Our team is actively monitoring the situation.

We apologize for the inconvenience and appreciate your patience while we work on getting things back to normal. Please stay tuned for further updates, and thank you for your understanding.
Posted Mar 05, 2024 - 16:03 UTC