slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Issues with loading Google Slides Integration
Incident Report for Slido
Resolved
This issue has now been resolved and all systems are fully operational again
Posted Jan 16, 2025 - 08:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 15, 2025 - 21:16 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 15, 2025 - 18:33 UTC
Identified
We are currently experiencing some issues with loading of our Google Slides integration currently. Some users report that our sidebar loads a blank screen. In some cases, refreshing the page helps resolve the issue.

This is due to an error on the Google side. We are working and in touch with them to resolve and restore service as soon as possible.

In case you are experiencing any other problems, please contact support@slido.com
Posted Jan 15, 2025 - 16:21 UTC
This incident affected: Slido Presentation Integrations (Google Slides Integration).