slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Major Outage of United Arab Emirates region

Incident Report for Slido

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 10:37 UTC

Identified

The issue has been identified and is due to vendor disruptions affecting UAE datacenters. We are actively monitoring services in UAE but there is nothing we can do at the moment. We do not have a recovery estimation from UAE datacenters at the moment. We will keep you updated.
Posted Mar 02, 2026 - 09:56 UTC

Investigating

We’re aware of an issue causing a major outage that’s impacting Slido services at slido.com and integrations for our UAE datacenters. Other datacenters are not impacted and Slido operates smoothly there. Our team is actively investigating and working to understand the full scope and resolve the problem.
Posted Mar 02, 2026 - 09:36 UTC
This incident affects: Slido Video Integrations (Webex Integration, Microsoft Teams Integration, Zoom Integration), Slido Presentation Integrations (PowerPoint for Windows Integration, PowerPoint for Mac Integration, Google Slides Integration), Slido web app - Host access, Slido web app - Participant access, and Slido API (United Arab Emirates API).