We have confirmed that the login issues affecting Webex users outside the EU have been resolved.
The latest fix has restored normal login access, and our monitoring shows the service is operating normally.
We apologize for the inconvenience and appreciate your patience.
Posted Jun 10, 2026 - 10:27 UTC
Monitoring
We have released another fix for the login issues affecting Webex users outside the EU. Users should now be able to log in normally.
Our team is monitoring the service to confirm the issue is fully resolved. If you are still experiencing login issues, please contact us at https://www.slido.com/contact.
We apologize for the continued inconvenience and appreciate your patience.
Posted Jun 10, 2026 - 10:01 UTC
Investigating
We are continuing to investigate login issues affecting some Slido users. The latest reports appear to be related to the earlier login incident, and our team is working to confirm the cause and restore stable access.
We apologize for the continued inconvenience and will share another update as soon as we have more information. If you need urgent assistance, please contact us at https://www.slido.com/contact.
Posted Jun 10, 2026 - 08:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 10, 2026 - 07:12 UTC
Monitoring
We identified the cause of the issue preventing some Webex users from logging in to Slido and released a fix. Users should now be able to log in normally.
We are monitoring the service to confirm the issue is fully resolved. If you’re still experiencing login issues, please contact us at https://www.slido.com/contact.
Posted Jun 10, 2026 - 07:08 UTC
Investigating
We have detected an issue preventing some users from logging in to Slido. Our team is actively working to restore full access as swiftly as possible. (optional: If you've managed to log in, your service should be unaffected.)
We'll keep you posted with the latest information. If you're in need of urgent assistance, please contact us at https://www.slido.com/contact.
We apologize for the inconvenience, and appreciate your patience.
Posted Jun 10, 2026 - 02:01 UTC
This incident affected: Slido Video Integrations (Webex Integration).