slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Updates not loading on Slido present view
Incident Report for Slido
Resolved
Between 1.50pm CET & 3.28pm CET on Wednesday 25th January, Slido users may have experienced issues with receiving new participant questions on the present view.

These problems were due to a release which has now been reverted. Slido's present view should now be updating as expected. If you are still experiencing issues, please refresh the page by using Shift+Cmd (Apple) or Ctrl+R (Windows).

We are sorry for any inconvenience this caused to you and your meetings, if you have any feedback or are still facing problems, please contact support@slido.com.
Posted Jan 25, 2023 - 12:30 UTC