All Help Center articles are available and operational since 15:33 UTC. This incident has been resolved.
Posted Aug 06, 2025 - 17:35 UTC
Monitoring
A fix by our third-party provider has been implemented. We are monitoring our Help Center availability and its performance.
Posted Aug 06, 2025 - 15:34 UTC
Identified
Our third-party provider already identified the issue and a fix is being implemented.
Posted Aug 06, 2025 - 14:47 UTC
Investigating
Our Help Center articles are currently not accessible since 14:05 UTC. Other parts of our Community are working without any issues. We've identified that issue is caused by the underlying third-party provider.
While we always aim to provide a seamless experience for our customers, this situation is completely owned by our third-party provider and unfortunately, our hands are tied. We hope that your experience won’t be significantly affected by this downtime. If you do need urgent assistance, please reach out to us at support@slido.com.