slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Degraded performance
Incident Report for Slido
Resolved
Our team managed to resolve the issue after it was identified and we will take the necessary steps to prevent this from happening again.

This is not the experience we are committed to delivering to you and we hope it didn't negatively affect your meeting or event. If you have any other questions, please let us know at support@slido.com. Have a wonderful weekend!
Posted Apr 01, 2022 - 16:04 UTC
Investigating
We are investigating issues that might be affecting our customers. Some actions or interactions with Slido or Slido API might be slower than usual. Our team is on it and trying to identify the root-cause. Please bear with us as we continue to investigate.
Posted Apr 01, 2022 - 14:56 UTC
This incident affected: Slido API (Europe API), Slido Video Integrations (Webex Integration), and Slido web app - Host access, Slido web app - Participant access.