slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Major Outage

Incident Report for Slido

Resolved

The issue has now been resolved and the service is operating normally again. Thank you for your patience while this was being addressed.
Posted Mar 02, 2026 - 09:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 09:23 UTC

Investigating

We’re aware of an issue causing a major outage for Webex users that’s impacting all Slido services at slido.com and integrations. The issue appears to be related to Webex authentication and login, most likely due to disruptions affecting UAE AWS datacenters. Our team is actively investigating and working to understand the full scope and resolve the problem.

We’ll provide updates here as soon as we have more information. Thank you for your patience.
Posted Mar 02, 2026 - 09:00 UTC
This incident affected: slido.com, Slido Video Integrations (Webex Integration), and Slido API (United Arab Emirates API).