Unavailable Help Center
Incident Report for Slido
Resolved
This incident has been resolved.
Posted May 03, 2020 - 20:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2020 - 14:21 UTC
Identified
Our Help Center is currently unavailable; as a result, our help articles can't be accessed. We've identified that issue is caused by the underlying third-party provider.

While we always aim to provide a seamless experience for our customers, this situation is completely owned by our third-party provider and unfortunately, our hands are tied. We hope that your experience won’t be significantly affected by this downtime. But if you do need urgent assistance, please reach out to us at support@slido.com.

Thank you for your understanding and patience.
Posted May 03, 2020 - 13:06 UTC
This incident affected: slido.com website.