slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Degraded performance

Incident Report for Slido

Resolved

The issue has now been resolved and the service is operating normally again.
The problem was caused by an AWS-related outage. We’ve confirmed that DNS lookups are functioning as expected and are continuing to monitor the situation closely.
Thank you for your patience while this was being addressed.
Posted Feb 10, 2026 - 22:13 UTC

Identified

We have identified the cause of the issue as a disruption originating from AWS. Our team is actively monitoring the situation.
For more details, please see the AWS update here: https://health.aws.amazon.com/health/status
We’ll continue to share updates as more information becomes available. Thank you for your patience.
Posted Feb 10, 2026 - 21:47 UTC

Investigating

We're currently experiencing issues with domain resolution and are investigating the cause. We've noticed Slido isn't as speedy as usual, which may cause slower performance and longer response times for some users. Our technical team is actively investigating, and we'll update you here as soon as we have more information.

Should you require immediate assistance, please contact support@slido.com.

Thank you for your patience.
Posted Feb 10, 2026 - 21:14 UTC
This incident affected: Slido API (Europe API, United States API, Canada API, United Arab Emirates API, Australia API), slido.com, Slido web app - Host access, Slido web app - Participant access, Supporting Services, Slido Video Integrations (Webex Integration, Microsoft Teams Integration, Zoom Integration), and Slido Presentation Integrations (PowerPoint for Windows Integration, PowerPoint for Mac Integration, Google Slides Integration).