Connectivity issues for some users
Incident Report for Slido
Resolved
This incident has been resolved.
Posted 11 months ago. Jan 16, 2018 - 19:33 CET
Monitoring
Everything is now looking clear from our side and all users should be able to connect to their events once more. Please let us know at support@slido.com or via our Live Chat if you are still experiencing problems. We apologize for disrupting your day and thank you for your patience.
Posted 11 months ago. Jan 16, 2018 - 19:11 CET
Identified
Identified - We've received reports that some users are currently having trouble connecting to Slido. We're working hard to fix this as quickly as we can. Thank you so much for bearing with us.
Posted 11 months ago. Jan 16, 2018 - 18:39 CET