slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Invoice Services

Incident Report for Slido

Resolved

A fix on a Braintree side has been implemented and incident is now resolved. Our team confirmed payments are working correctly. We apologize for the inconvenience.
Posted Nov 18, 2025 - 12:58 UTC

Identified

Our payment supplier Braintree is currently experiencing issues. This is impacting the ability to purchase or renew Slido online. We will update once this is resolved or you can follow their status page: https://paypal-status.com/product/production
In the meantime, if you'd like to buy Slido, please contact support@slido.com
Posted Nov 18, 2025 - 12:18 UTC
This incident affected: Supporting Services.