slido

Subscribe for real-time Slido service status updates.

For status information about other Cisco products or services, please visit the Cisco Status page.


Issue with quiz timer

Incident Report for Slido

Resolved

Our team managed to resolve the issue. We will investigate this incident and ensure we take the necessary steps to prevent this from happening again.

This is not the experience we are committed to delivering to you and we apologize to all whose meetings or events were negatively affected by this disruption. If you have any other questions, please let us know at support@slido.com.
Posted Nov 26, 2025 - 18:24 UTC

Identified

The issue has been identified and confirmed that it is only impacting the timer in quizzes.

Previously created quizzes should operate without issue as long as you don’t try to change the timer.

The timer on newly created quiz questions will be unable to be changed from 20 seconds.running the quiz will still be fine.
Posted Nov 26, 2025 - 18:17 UTC

Investigating

We’re aware of an issue with Slido’s quiz feature, which is impacting the ability to adjust the timer and mark the correct answer. The rest of the service remains unaffected and is operating smoothly.

Our engineering team is on the case to resolve this promptly. Updates will be shared as we have them. If this issue is impacting your workflow and you need immediate assistance, don't hesitate to reach out at support@slido.com.

Thank you for your patience as we work through this.
Posted Nov 26, 2025 - 18:05 UTC
This incident affected: Slido API (Europe API, United States API, Canada API, United Arab Emirates API, Australia API).